Frissítés a PHP PHP 5.1.x 5.3 5.6 CentOS

legtöbb CMSnövények, beleértve a Van egy minimális követelmény a telepít újabb változata 5.1.x pe . A bemutató alatt, hogy mutassa meg néhány egyszerű lépést, hogy tudsz frissíteni a PHP PHP 5.1 5.3.x pe   5.6.

1. Először is véget kell vetni web szerver. (Service httpd)

service httpd megálló

2. Tiszta 5.1.x PHP csomag telepítve a szerverre.

yum távolítsa php PHP *

3. Miután megkaptuk annak megerősítését, hogy a PHP csomag törölték a szerverről, menjen a csomagok telepítése PHP 5.3.

yum install php53.i386
yum install-bcmath.i53 php386
yum install php53-cli.i386
yum install php53-common.i386
yum install php53-dba.i386
yum install-devel.i53 php386
yum install php53-gd.i386
yum install-imap.i53 php386
yum install php53-intl.i386
yum install php53-ldap.i386
yum install-mbstring.i53 php386
yum install-mysql.i53 php386
yum install php53-odbc.i386
yum install php53-pdo.i386
yum install-pgsql.i53 php386
yum install-process.i53 php386
yum install-pspell.i53 php386
yum install php53-snmp.i386
yum install-soap.i53 php386
yum install-xml.i53 php386
yum install-xmlrpc.i53 php386

Vagy még egyszerűbb, válogatott csomag php53 *.

php53 telepíteni *

4. Indítsa Apache Web Server

szolgáltatás httpd start

csomagok php53-körte, php53-mcrypt, php53-Mhash, php53 OEM, php53-pear-apc si php53-pear-memcache nem áll rendelkezésre CentOS 5.6.

Végül ellenőrizze PHP5.3 változat sikeresen telepítve. Hozzon létre egy .php fájlt (pl info.php.), Hogy:

<? Php

phpinfo ();

phpinfo (INFO_MODULES);

?>

Mászni a szerver és a hozzáférést fájlt Firefox címét, , vagy bármely más böngésző. Az eredmény:

php info

Láthatjuk, hogy milyen verziójú PHP van telepítve a szerverre a parancssorban: php-v vagy "yum lista telepített | grep php"(Megjeleníti az összes PHP csomag telepítve van).

yum lista telepített php

Frissítés / Install PHP CentOS 5.3 5.6.

Frissítés a PHP PHP 5.1.x 5.3 5.6 CentOS

A szerzőről

Stealth LP

Alapítója és szerkesztője Stealth beállításokA 2006 dátumot.
A tapasztalat Linux operációs rendszerek (különösen CentOS), Mac OS X, Windows XP> Windows 10 és a WordPress (CMS).

Leave a Comment

Ez az oldal Akismet-et használ a levélszemét csökkentése érdekében. Ismerje meg, hogyan dolgozik a megjegyzésed.