Javítási hiba: Úgy tűnik, hogy a PHP telepítésében hiányzik a WordPress által megkövetelt MySQL kiterjesztés

"Úgy tűnik, hogy a PHP telepítéséből hiányzik a WordPress által megkövetelt MySQL kiterjesztés"Hiba, amelyet sok blogtulajdonos és webhely tart WordPress.
Ez nem ad okot aggodalomra. A MySQL kiterjesztés hiánya A PHP-től a nulláról telepített operációs rendszerekre, VPS-re vagy dedikált szerverekre jellemző, ahol a PHP kiterjesztések nem voltak a telepítő csomag része. Ez a probléma mindkettőnél fennáll Ubuntu és a CentOS. Ebben a forgatókönyvben a problémát nagyon egyszerűen oldják meg egy PHP frissítéssel és a modul telepítésével "php-mysql".
Frissítse a PHP-t, és telepítse a MySQL kiterjesztést az Ubuntu-ra

apt-get update
apt-get install php-mysql

Frissítse a PHP-t, és telepítse a MySQL kiterjesztést a CentOS-ra

yum update
yum install php70w-mysql

Ezt a lépést követően Indítsa újra az Apache szolgáltatást vagy nginx.

Arra is találkoztam, hogy bár a MySQL kiterjesztés létezik a PHP-ben, a WordPress-ben létrehozott blogban a következő hibaüzenet jelenik meg: "Úgy tűnik, hogy a PHP telepítéséből hiányzik a WordPress által megkövetelt MySQL kiterjesztés". A hiba általában a WordPress telepítésekor jelentkezik. Ezúttal azonban egy blogban jelent meg, amely évek óta aktív.
Ebben a helyzetben azt tapasztaltam, hogy a probléma nem a PHP modulok, hanem a WordPress nagyon régi verziója, amely már nem kompatibilis a PHP 7.4.4RC1-rel. A hibát egy egyszerű WordPress frissítés a legújabb verzióra oldotta meg.

Javítási hiba: Úgy tűnik, hogy a PHP telepítésében hiányzik a WordPress által megkövetelt MySQL kiterjesztés

A szerzőről

Lopakodás

Szenvedélyesen foglalkozik mindazokkal, amelyek eszközöket és informatikai eszközöket mutatnak, örömmel írom a stealthsettings.com webhelyre az 2006-től, és szeretek új dolgokat felfedezni a számítógépekről és a MacOS-ról, a Linux operációs rendszerekről, Windows, iOS és Android.

Írj hozzászólást