PROBLÉMA MEGOLDÁSA: A szerverén a PHP 5.1.6-os verziója fut, de WordPress 3.2.1 legalább 5.2.4.

Megjegyzés az összes nem ismert, hogy felszerel , vagy nem frissítésA újabb verziója 3.2Szükséges, hogy kell telepíteni egy újabb verziója 5.2.4.

Ha a kiszolgáló telepítése változata PHP idősebb 5.2.4, telepítése verzió WordPress 3.2.1Jelenik meg hiba / az üzenet: "A szerveren a PHP 5.1.6 verziója fut, de WordPress 3.2.1 legalább 5.2.4".
A probléma megoldható nagyon egyszerűen korszerűsítése PHP, de előtte még néhány dolgot figyelembe kell venni. Először is, upgrade PHP lehetőség a megosztott tárhely. A frissítéshez hozzáféréssel kell rendelkeznie a administrator szerveren (Dedikált szerver vagy VPS). A második, a frissítés előtt dokumentálnia kell, és tudatában kell lennie, hogy az új verziója PHP nem ad hibák más oldalak az adott kiszolgálón tárolt.

mert az operációs rendszert használják webszerverek (Agreart és / WHM) Megmutatja, hogyan kell csinálni frissítés PHP 5.2.10-re CentOS 5.x 32 bites.

Frissítse a PHP 5.1.x-et 5.2.x-re CentOS 5.x 32 bites

1. Ellenőrizze, hogy melyik csomag / modules telepítése PHP (pl. php-mcrypt) mellett a szokásos csomagot. Ha léteznek, törlődnek vagy actuzlizate.

Ellenőrzése telepített csomagok:

rpm -qa | grep php
old_php_version

2. Az extra tárolók Kötelező frissítés'S PHP verzió.

nano /etc/yum.repos.d/CentOS-Testing.repo

Az új fájl (CentOS-Tesztelés.repo) Növeli a következő sorokat (másolás / beillesztés):

[c5-testing] 
name=CentOS-5 Testing 
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/ 
enabled=1 
gpgcheck=1 
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing 
includepkgs=php*

Ctrl + X a fájl mentéséhez CentOS-Tesztelés.repo.

3. Update PHP a yumon keresztül:

yum update

4. Újraindítás / httpd :

service httpd restart

A httpd újraindítása után ellenőrizze a verziót és a telepített csomagokat:

new_php_version

Ellenőrizze a hibákat modules / csomag:

php -v

- PHP frissítés / CentOS 32 bites (i386).

Alapítója és szerkesztője Stealth Settings, 2006-tól napjainkig. Operációs rendszerekben szerzett tapasztalat Linux (Különösen CentOS), Mac OS X, Windows XP> Windows 10 és WordPress (CMS).

Hogyan » Linux » PROBLÉMA MEGOLDÁSA: A szerverén a PHP 5.1.6-os verziója fut, de WordPress 3.2.1 legalább 5.2.4.

Írj hozzászólást

Best tutorials in your language:
EN - DE - DA - FR - ES - IT - PT - NL - NO - FI - SV - PL - HR - SL - CS - SK - TR - EL - LV - ET - LT - BG - UK - RU - HU - ID - VI - HI - JA - KO - TH - ZH-CN - ZH-TW - IW - AR